Pertanyaan Editor teks Atom menghapus spasi kosong di simpan


saya menggunakan Sublime text. Sekarang saya sedang mencoba Atom. Ketika saya menyimpan file apa pun dalam teks luhur itu tidak termasuk baris kosong trailing. Tetapi menyimpan file apa pun di Atom meninggalkan garis kosong di belakangnya. Bagaimana cara saya memaksa Atom tidak meninggalkan ruang putih yang tertinggal?


76
2018-05-22 18:04


asal


Jawaban:


Di bawah Atom Anda Preferences pergi ke Packages tab dan cari whitespace. Klik pada whitespace paket dan hapus centang Ensure Single Trailing Newline pilihan

enter image description here


134
2018-05-22 18:16



Di tingkat global ini dapat diubah menggunakan settings di Whitespace paket, tetapi jika Anda ingin menonaktifkannya untuk bahasa tertentu Anda harus menggunakan properti-lingkup sintaksis di config.cson Anda.

'.text.html.php': # php overrides
  whitespace:
    ensureSingleTrailingNewline: false
    removeTrailingWhitespace: false

'.source.ruby': # ruby overrides
  whitespace:
    ensureSingleTrailingNewline: false
    removeTrailingWhitespace: false

Untuk melihat lingkup bahasa masuk Packages tab dan cari bahasa Anda.

Klik pada pengaturan paket bahasa dan Anda dapat melihat ruang lingkup:


13
2018-02-10 11:10



Pergi ke paket dan temukan "spasi", pergi ke pengaturan itu dan hapus centang pada kotak centang terakhir.

Pengaturan Settings screenshot

Kotak centang Checkbox screenshot


2
2018-04-10 10:04