Pertanyaan Lighttpd 403 Forbidden untuk file PHP


Saya baru saja menginstal lighttpd di server khusus saya, mod_fastcgi diaktifkan, jadi saya menambahkan baris berikut ke lighttpd.conf mengajukan:

fastcgi.server = ( ".php" =>
( "localhost" =>
                     (
                        "socket" => "/tmp/php-fastcgi.socket",
                        "bin-path" => "/usr/local/bin/php-cgi"
                      )
                   )
)

Tapi itu tetap tidak membantu, karena saya mendapatkan 403 - Forbidden pesan ketika saya mencoba memasukkan file PHP di browser web saya ... Ketika saya menghapus index.php file dari direktori root web saya dan tempatkan index.html di sana, maka semuanya baik-baik saja, dan tidak ada kesalahan, tidak masalah index.php file memiliki 100 baris atau hanya satu - <?php echo 'test'; ?> itu selalu muncul 403 - Forbidden, Saya kehabisan ide sekarang.

Mengapa itu terjadi?

ls -la direktori root web saya:

#
total 6

    drwxr-xr-x  15 root  wheel   1536 Jul 18 10:23 .
    drwxr-xr-x   4 root  wheel    512 Jul 18 08:45 ..
    drwxr-xr-x   2 www   www      512 Jul  1 02:36 cache
    drwxr-xr-x   2 www   www      512 Jul  1 02:36 config
    drwxr-xr-x   6 www   www      512 Jul  1 02:36 inc
-rw-r--r--   1 www   www        9 Jul 18 11:02 index.php

18
2017-07-18 09:07


asal


Jawaban:


Php Anda tidak dikonfigurasi dengan benar. periksa lighttpd error.log Anda itu akan menyatakan sesuatu seperti:

(mod_fastcgi.c.1397) [ERROR]: spawning fcgi failed. 

saya menggunakan:

fastcgi.server = ( ".php" => ((                                      
                     "bin-path" => "/bin/php-cgi",             
                     "socket" => "/tmp/php.socket",              
                     "max-procs" => 1,                                     
                     "bin-environment" => (                         
                       "PHP_FCGI_CHILDREN" => "16",                    
                       "PHP_FCGI_MAX_REQUESTS" => "10000"           
                     ),         
                     "broken-scriptfilename" => "enable"
                 )))   

pastikan bahwa fastcgi diaktifkan di modules.conf

server.modules = (
  "mod_access",
  "mod_fastcgi",
#  "mod_alias",
#  "mod_auth",
#  "mod_evasive",
#  "mod_redirect",
#  "mod_rewrite",
#  "mod_setenv",
#  "mod_usertrack",
)

14
2017-08-20 08:18



Masalah yang sama, perbaikan untuk Mint adalah menginstal paket php5-cgi.
sudo apt-get install php5-cgi 
aktifkan modul fastcgi
sudo lighttpd-enable-mod fastcgi fastcgi-php 
dan akhirnya kembali
sudo service lighttpd force-reload


10
2017-11-05 06:52



Saya memiliki masalah yang sama. Perbaikan itu sesederhana memindahkan file konfigurasi sehingga ada diaktifkan. Yang saya lakukan adalah ...

$ ln -s /etc/lighttpd/conf-available/10-fastcgi.conf /etc/lighttpd/conf-enabled/
$ ln -s /etc/lighttpd/conf-available/15-fastcgi-php.conf /etc/lighttpd/conf-enabled/

dan kembali ...

$ service lighttpd force-reload

6
2017-07-16 20:38



Di ubuntu Anda dapat melakukan ini:

sudo lighty-enable-mod fastcgi 
sudo lighty-enable-mod fastcgi-php

Sumber: https://wiki.ubuntu.com/Lighttpd%2BPHP


2
2018-04-03 17:03



Tidak mungkin, tetapi harus dicatat sebagai alasan lain yang mungkin untuk "403 Forbidden" tanggapan.

Periksa pernyataan modul akses (mod_access) di file konfigurasi (lighttpd.conf)

Contoh:

      url.access-deny = ( "", ".php");

Docs: Modul mod_access


1
2018-02-26 02:19