Pertanyaan Java FX untuk SE7 atau SE8


Saya akan membuat aplikasi Java menggunakan Java FX. Saya ingin menggunakan SE8, tapi saya khawatir bahwa Java FX tidak dapat digunakan di SE8 seperti SE7; Adakah yang menggunakan Java FX di SE8 dan dapat mengkonfirmasi bahwa itu tidak bermasalah atau sulit digunakan? Terima kasih, saya tidak ingin beralih platform di tengah jika menjadi berantakan!


4
2018-04-15 01:52


asal


Jawaban:


Tinjau jawaban untuk: Apakah ada changelog JavaFX 8?

Kemudian putuskan sendiri jika Anda lebih suka menggunakan Java 7 atau Java 8, mengingat bahwa:

  1. Banyak bug dalam implementasi JavaFX di Java 7 telah diperbaiki di Java 8.
  2. Banyak fitur ditambahkan ke JavaFX di Java 8 yang tidak ada di Java 7.
  3. Banyak sekali peningkatan kinerja arsitektur diimplementasikan untuk Java 8.
  4. Tanggal saat ini dijadwalkan untuk akhir pembaruan publik untuk Java 7 adalah April 2015.
  5. Pengembang proyek JavaFX jarang mendukung perbaikan bug dari cabang Java 8 ke cabang sebelumnya.

Apakah JavaFX di Java 8 bebas bug? => Tidak

Pembaruan pembaruan Java 8u20 akan menyertakan banyak perbaikan bug (sebagian kecil) untuk JavaFX.

Rilis pembaruan Java 7 mendatang tidak akan menyertakan sebagian besar perbaikan bug ini.

Apakah JavaFX di Java 8 memiliki lebih sedikit bug dari JavaFX di Java 7? => Tentu saja.

Masalah utama dengan pengembangan JavaFX di Java 8 saat ini adalah SceneBuilder alat untuk Java 8 hanya dalam rilis akses awal. Namun, itu akan memiliki rilis produksi segera dan rilis akses rilis awal terbaru untuk SceneBuilder cukup bermanfaat.


5
2018-04-15 02:25