Pertanyaan Kesalahan - Tidak dapat mengakses metabase IIS


Setelah menginstal Visual Studio 2012 dan membuka solusi saya, saya mendapatkan serangkaian kesalahan dalam formulir ini:

Proyek Aplikasi Web Foo dikonfigurasi untuk menggunakan IIS.
  Tidak dapat mengakses metabase IIS. Anda tidak memiliki hak istimewa yang memadai untuk mengakses situs web IIS di komputer Anda.

Saya mendapatkan ini untuk setiap aplikasi web kami. Hal-hal yang saya coba:

  1. Menjalankan Visual Studio sebagai Administrator
  2. Menjalankan aspnet_regiis.exe -ga MyUserName
  3. Menjalankan aspnet_regiis.exe -i

Ini tampaknya menjadi solusi umum untuk masalah ini tetapi saya belum pernah berhasil dengan mereka. Apakah ada hal lain yang bisa saya coba lakukan?


762
2017-10-12 13:15


asal


Jawaban:


Di Windows 8 Pro:

%systemroot%\inetsrv\config

Di Windows 7 dan 8.1 dan 10

%systemroot%\System32\inetsrv\config 

(Dimana %systemroot% biasanya C:\Windows)

Arahkan ke lokasi yang sesuai di atas di Windows Explorer. Anda akan memblokir akses dengan munculan yang mengatakan:

"Anda tidak memiliki akses ke folder ini - Klik terus untuk mendapatkan akses ke folder ini secara permanen"

Klik 'lanjutkan' untuk folder ini, dan dengan folder Ekspor di bawahnya. Saya mengubah pintasan kembali ke "Run as me" (anggota dari domain dan administrator lokal) dan dapat membuka dan menyebarkan solusi.


1349
2017-07-04 01:58



Saya pikir Anda tidak menjalankan studio visual dengan izin administrator. Lihat itu:

http://bloggingabout.net/blogs/rick/archive/2012/10/04/unable-to-access-the-iis-metabase.aspx

Kutipan

Solusi untuk ini sederhana: mulai Visual Studio Anda dengan "Run as   Administrator ". Anda dapat melakukan ini dengan mengklik kanan pintasan dan   memilih "Run as Administrator".


235
2017-10-12 13:19



Saya pikir kami mengalami masalah serupa di tempat kerja. Bagi kami, solusinya adalah pergi ke Control Panel -> Program dan Fitur -> Turn Fitur Windows on atau off ... di dalamnya, kami harus memilih Layanan Informasi Internet -> Alat Manajemen Web -> IIS 6 Manajemen Kompatibilitas -> IIS Metabase dan IIS 6 konfigurasi kompatibilitas. Windows Features dialog showing IIS Metabase option

Berikan itu coba dan beri tahu saya jika itu membantu!

Catatan: Kami menjalankan IIS 7.5 pada Windows 7 menggunakan Visual Studio 2005 dan 2010 dan melakukan hal-hal dengan super-old-school WebServices (.asmx) ...


47
2017-10-12 13:39



Saya menyelesaikan masalah ini dengan memberikan izin identitas IIS AppPool ke %systemroot%\inetsrv\config


31
2018-05-05 22:06



Jika Anda bekerja pada proyek yang tidak memerlukan penggunaan IIS, maka solusi untuk membuka proyek dengan kesalahan ini adalah cukup klik kanan pada proyek yang tidak dimuat dan klik edit, cari:

<ProjectExtensions>
    <VisualStudio>
      <FlavorProperties GUID="">
        <WebProjectProperties>
          <UseIIS>True</UseIIS>
        </WebProjectProperties>
      </FlavorProperties>
    </VisualStudio>
  </ProjectExtensions>
</Project>

dan mengatur USEIIS menjadi salah

<UseIIS>False</UseIIS>

reload proyek dengan mengklik kanan setelah menyimpan perubahan.


25
2017-08-06 05:57



Saya memiliki dua jenis masalah yang berbeda mengarah pada kesalahan ini, dan saya pikir saya akan berbagi ...

1. The directory was on an network share and due to UAC restrictions, was 
   unable to be accessed -- even when running as an admin.
2. The directory was on a drive that didn't exist...

Kedua hal ini berasal dari pilihan yang tidak menguntungkan (imo) oleh MS untuk meletakkan segala sesuatu di Dokumen atau direktori Dokumen Saya, padukan dengan pesan kesalahan yang benar-benar buruk. Dalam kedua kasus di atas masalah mendasar adalah bahwa File Konfigurasi IISExpress masuk dalam My Documents, dan itu tidak ada atau tidak bisa diakses.


18
2017-10-04 06:38



Terima kasih untuk semua yang menjawab. Karena ini sudah lama ditutup, saya tidak bisa memberikan banyak umpan balik, tetapi akhirnya saya memperbaiki masalah saya. Saya mencoba banyak solusi lain dan mereka tidak memperbaiki masalah saya, tetapi saya yakin itu membantu ketika akar penyebabnya berbeda.

Solusi saya

Saya memecahkan masalah ini dengan mematikan fitur IIS dan .Net Framework dalam Windows 7 dan kemudian menyalakannya kembali. Sepertinya instalasi ulang ini yang memperbaiki masalah saya. Saya masih tidak tahu apa yang menyebabkan masalah, tetapi setidaknya satu pengembang lain di tim saya memiliki masalah yang sama.


12
2018-02-05 19:30



Saya memiliki masalah ini - gejalanya sama, tetapi masalah yang saya hadapi adalah bahwa saya telah mengatur folder "My Documents" untuk menjadi bagian jaringan, dan pembagiannya tidak dapat diakses.

Masalah utamanya adalah file konfigurasi IIS yang terletak di% USERPROFILE% \ Documents tidak dapat diakses. Setelah saya mengubah lokasi folder "My Documents" (saya memodifikasi nilai reg), itu mulai bekerja lagi.

Saya tahu bahwa ini mungkin bukan skenario umum yang mungkin Anda alami, tetapi saya mempostingnya di sini karena memberikan gejala yang sama.


11
2018-02-15 22:15



Pada jendela 81, dari command prompt admin, gunakan:

icacls "C:\Windows\System32\inetsrv\config" /t /grant "IIS AppPool\DefaultAppPool":(R)

Lalu kembali ke VS, klik kanan pada proyek yang gagal, pilih Reload.

Kredit ke: IIS7 Izin Tinjauan - ApplicationPoolIdentity


10
2017-09-09 15:12



Anda mungkin mengalami masalah ini dan memiliki masalah yang sama dengan saya. Saya "menyelesaikan" sebelumnya dan kemudian pemadaman listrik dan komputer jatuh, tidak yakin mengapa registri pengaturan dikembalikan tetapi itu adalah SUMBER masalah saya.

  1. Saya mencoba semua yang berjalan sebagai adminstrator
  2. Semua IIS / IIS express menginstal ulang.
  3. Berbagai "hacks"

Datang untuk memperbaiki registri lagi.

  1. Tidak bisa sebagai administrator bahkan membuka regedit (Perlu untuk mengakses registri karena masalah tidak dengan template admin gpedit.msc)

  2. UnHookExec.inf di desktop

Simpan saja UnHookExec.inf dan instal dengan mengklik kanan dan memilih instal. Memasang file tidak akan menampilkan sembulan atau kotak pemberitahuan. http://www.tweakandtrick.com/2011/04/enable-regedit-registry-editor.html

  1. HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ User Shell Folders \ Personal menunjuk ke fileshare tidak ada. Mengubah itu ke jalan lokal memecahkan masalah ini untukku. - Pasi Savolainen 14 Jul '14 jam 8:41

(diubah dari \\cs2data\home\stickelt\my documents  untuk c:\dev  )

Sekarang Semua baik dan Visual Studio membuka solusi dengan 15 proyek dan terhubung ke IIS dan tidak mengeluh tentang tidak dapat mengakses iis metadata

Saya belum pernah mengalami ini sebelumnya, karena tidak ada orang di pekerjaan saat ini yang memiliki masalah ini (banyak yang sudah lama di sini, beberapa mendapat klon dari mesin lain yang "bekerja" dan banyak yang berada di domain lain dll ..)


7
2017-07-01 20:11