Pertanyaan Gunakan sudo dengan .vimrc


Saya menggunakan CentOS dan membuat a .vimrc file di saya /home direktori. Saya mengujinya dengan membuat file txt dan ya, itu berfungsi dengan baik. Sekarang, saya punya file proyek saya di /srv direktori dengan SELinux dihidupkan. Saya mencoba membuka file: vim README.txt dan ya, saya .vimrc pengaturan masih diterapkan.

Sekarang, karena saya ada di /srv direktori, cukup lakukan vim artinya file saya hanya bisa dibaca. Jadi, saya lakukan sudo vim README.txt agar dapat mengedit file. Sekarang, masalahnya terletak pada saat saya melakukannya sudo, tidak ada satupun dari saya .vimrc pengaturan diterapkan. Saya mencoba membuat salinannya .vimrc dalam /srv folder tetapi itu tidak berhasil.

Bagaimana saya mendaftar .vimrc pengaturan saat menggunakan sudo?


33
2018-01-31 19:22


asal


Jawaban:


Menggunakan sudoedit dari pada sudo vim. Anda harus melakukan hal itu. Pastikan Anda EDITOR variabel lingkungan diatur ke vim (mungkin sudah, atau vim adalah default; Anda dapat mengaturnya di Anda .profile analog jika perlu).


58
2018-01-31 19:26



Seperti yang ditunjukkan sini, Anda dapat menggunakan yang berikut:

sudo -E vim README.txt

Dari halaman manual:

-E    The -E (preserve environment) option indicates to the security policy that the user wishes to preserve their existing environment variables.  The
  security policy may return an error if the -E option is specified and the user does not have permission to preserve the environment.

Jawaban yang diterima adalah yang paling aman. Tapi yang ini lebih fleksibel yang bisa saya gunakan sudo -E operation dengan operasi apa pun, saya tidak perlu mengonfigurasi yang lain sebelumnya.


17
2017-11-07 23:24



Solusi yang disajikan dalam tanggapan lain bekerja tetapi tidak terlalu praktis, karena Anda harus memasukkan kata sandi setiap kali Anda ingin mengedit file.

Saya biasanya punya tmux sesi terbuka di mana saya di-root via sudo su, jadi saya memasukkan kata sandi saya sekali di awal sesi dan kemudian dapat bekerja berjam-jam tanpa harus memasukkannya lagi.

Saya bekerja di sekitar masalah yang disajikan di sini dengan membuat tautan simbolis berikut: sudo su ln -s /home/MY-USER-NAME/.vimrc .vimrc ln -s /home/MY-USER-NAME/.vim .vim

Anda mungkin perlu menghapus /root/.vim/ direktori pertama.

saya harap ini membantu


0
2018-06-10 15:16